Uploaded image for project: 'GMAT'
  1. GMAT
  2. GMT-6094

OrbitView does not display correctly

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: P2
    • Resolution: Fixed
    • Affects Version/s: R2016a
    • Fix Version/s: None
    • Component/s: Orbit View (FRR-28)
    • Labels:
      None
    • Environment:

      Arch Linux x64, fresh R2016a-build, also happening on R2015.

      Description

      For all celestial bodies, there are graphics errors in the OrbitView. I was able to find the following systematics of the bug:

      • Both hemispheres are displayed correctly when viewing from below the body equator
      • When viewing from above the eqauator, you can see the "inside" of the planet, so the faces of the opposite side
      • When viewing from the equatorial plane (and +- some degrees), the body is tiled into parts that look OK and parts that show the anomalous behaviour

      Also, probably related:

      • Orbits are always drawn behind the celestial body, not in front where passing in front of them.

      Example:

      • Central Body: Earth
      • Looking from above Brazil: Earth looks good
      • Looking from above USA: Australia is visible, like when looking through the northern hemisphere

      I'm attaching three screenshots, visualizing the problem. This can be reproduced by running the default mission and just panning/rotating in the OrbitView.

        Gliffy Diagrams

          Attachments

            Activity

            djcinsb Darrel Conway added a comment -

            Some (maybe all) of this has been cleaned up, thanks to some contributed code, and should be part of the next release, coming soon.

            These bugs are at least partially hardware related, and don't show up on the Linux development platform which uses an Nvidia card and the proprietary drivers. The fix looks good on a test machine (Red Hat 7) that has Intel graphics. What hardware and graphics drivers are you using?

            thasti Stefan Biereigel added a comment -

            Ah, interesting. My investigations turned up nothing errorneus in the code, I expected some driver/openGL related issues there. I'm using a Lenovo Thinkpad X240 with Intel graphics and the i915 driver (xf86-video-intel). Is the working code already available in git/svn, so I could maybe test a new build?

            djcinsb Darrel Conway added a comment -

            Alas, GMAT development occurs behind a firewall at NASA Goddard. However, all that I did was apply the patch on GMT-5872. If you are building GMAT anyway, you could try that – the patch is pretty small. (GMT-5877 is also useful; it adds text to the OpenGL windows similar to the text Windows users see.)

            thasti Stefan Biereigel added a comment - - edited

            Works for me! Thanks for pointing me to GMT-5872 - I did search the bug DB but did not find anything related. Looking forward to the next release, keep up the good work!

            shughes Steven Hughes added a comment -

            Fix applied previously but not in public version. Will be in R2017a


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: