Uploaded image for project: 'GMAT'
  1. GMAT
  2. GMT-6081

Expose the max number of points for OrbitView buffer to user

    Details

    • Type: Improvement
    • Status: Closed (View Workflow)
    • Priority: P1
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Orbit View (FRR-28)
    • Labels:
      None
    • Sprint:
      Sprint-R2018a-1

      Description

      from ViewCanvas.hpp below, GMAT has a hard coded value of buffer size for points stored for OrbitView windows. We should allow the user to set that manually

      protected:

      enum
      {
      MAX_DATA = 20000,
      UNINIT_TEXTURE = 999,
      UNKNOWN_BODY = -1,
      UNKNOWN_OBJ_ID = -999,
      };

        Gliffy Diagrams

          Attachments

            Activity

            shughes Steven Hughes created issue -
            shughes Steven Hughes made changes -
            Field Original Value New Value
            Sprint Next Sprint [ 11 ]
            Description

            from ViewCanvas.hpp below, GMAT has a hard coded value of buffer size for points stored for OrbitView windows. We should allow the user to set that manually

            protected:

               enum
               {
                  {color:red}MAX_DATA = 20000,{color}
                  UNINIT_TEXTURE = 999,
                  UNKNOWN_BODY = -1,
                  UNKNOWN_OBJ_ID = -999,
               };
               

            from ViewCanvas.hpp below, GMAT has a hard coded value of buffer size for points stored for OrbitView windows. We should allow the user to set that manually

            protected:

               enum
               {
                  {color:red}MAX_DATA = 20000,{color}
                  UNINIT_TEXTURE = 999,
                  UNKNOWN_BODY = -1,
                  UNKNOWN_OBJ_ID = -999,
               };
               
            shughes Steven Hughes made changes -
            Assignee Rizwan Qureshi [ rqureshi ] Mike Stark [ mstark ]
            shughes Steven Hughes made changes -
            Sprint Next Sprint [ 11 ] Sprint-R2017a-3 [ 12 ]
            shughes Steven Hughes made changes -
            Rank Ranked higher
            mstark Mike Stark added a comment -

            Estimate includes time to read "How to" for creating/editing panels.

            mstark Mike Stark made changes -
            Remaining Estimate 3 days [ 86400 ]
            Original Estimate 3 days [ 86400 ]
            Description
            from ViewCanvas.hpp below, GMAT has a hard coded value of buffer size for points stored for OrbitView windows. We should allow the user to set that manually

            protected:

               enum
               {
                  {color:red}MAX_DATA = 20000,{color}
                  UNINIT_TEXTURE = 999,
                  UNKNOWN_BODY = -1,
                  UNKNOWN_OBJ_ID = -999,
               };
               
            from ViewCanvas.hpp below, GMAT has a hard coded value of buffer size for points stored for OrbitView windows. We should allow the user to set that manually

            protected:

               enum
               {
                  {color:red}MAX_DATA = 20000,{color}
                  UNINIT_TEXTURE = 999,
                  UNKNOWN_BODY = -1,
                  UNKNOWN_OBJ_ID = -999,
               };
               
            shughes Steven Hughes made changes -
            Assignee Mike Stark [ mstark ] Rizwan Qureshi [ rqureshi ]
            shughes Steven Hughes made changes -
            Assignee Rizwan Qureshi [ rqureshi ] Joshua Raymond [ jraymond ]
            djcinsb Darrel Conway added a comment -

            Feature is functional and in review

            djcinsb Darrel Conway made changes -
            Resolution Fixed [ 1 ]
            Status Open [ 1 ] Resolved [ 5 ]
            shughes Steven Hughes made changes -
            Assignee Joshua Raymond [ jraymond ] Darrel Conway [ djcinsb ]
            djcinsb Darrel Conway added a comment -

            Code is reviewed, committed, and pushed.

            djcinsb Darrel Conway made changes -
            Status Resolved [ 5 ] Closed [ 6 ]
            djcinsb Darrel Conway made changes -
            Sprint Sprint-R2017a-3 [ 12 ]
            djcinsb Darrel Conway added a comment -

            Passing to Tetyana for GUI test updates

            djcinsb Darrel Conway made changes -
            Status Closed [ 6 ] Reopened [ 4 ]
            Resolution Fixed [ 1 ]
            djcinsb Darrel Conway made changes -
            Resolution Fixed [ 1 ]
            Status Reopened [ 4 ] Resolved [ 5 ]
            djcinsb Darrel Conway made changes -
            Assignee Darrel Conway [ djcinsb ] Tetyana Royzman [ troyzman ]
            troyzman Tetyana Royzman added a comment -

            Started updating the tests.
            Each individual System test that runs OrbitView need to update separately.
            Also, the updates affected Regression OrbitView and GroundTrackPlot projects.

            troyzman Tetyana Royzman logged work - 09/Aug/17 1:57 PM
            • Time Spent:
              4 hours
               

              Working on update name mapping for the system 3D models tests.

            troyzman Tetyana Royzman logged work - 10/Aug/17 1:58 PM
            • Time Spent:
              5 hours
               

              Worked on fixing name mapping for OrbitView projects.

            shughes Steven Hughes made changes -
            Sprint Sprint-R2018a-1 [ 13 ]
            troyzman Tetyana Royzman made changes -
            Worklog Id 15658 [ 15658 ]
            Time Spent 4 hours [ 14400 ]
            Remaining Estimate 3 days [ 86400 ] 2 days, 4 hours [ 72000 ]
            troyzman Tetyana Royzman made changes -
            Worklog Id 15659 [ 15659 ]
            Time Spent 4 hours [ 14400 ] 1 day, 1 hour [ 32400 ]
            Remaining Estimate 2 days, 4 hours [ 72000 ] 1 day, 7 hours [ 54000 ]
            troyzman Tetyana Royzman logged work - 17/Aug/17 4:10 PM
            • Time Spent:
              6 hours
               

              updated name mapping, steps, and property checks for the regression projects

            troyzman Tetyana Royzman logged work - 18/Aug/17 4:10 PM
            • Time Spent:
              6 hours
               

              updated name mapping, steps, and property checks for the regression projects

            troyzman Tetyana Royzman logged work - 23/Aug/17 4:11 PM
            • Time Spent:
              6 hours
               

              updated name mapping, steps, and property checks for the system projects

            troyzman Tetyana Royzman added a comment -

            The GUI additional item affected ‘OrbitView’ and ‘GroundTrackPlot‘ projects’ name mapping and also affected all System keyword tests and steps. Fields’ name mapping have been changed and TestComplete couldn’t recognize them. It needed to fix and update name mapping, steps, and property checks; added new steps for the pass criteria for the most of the System test due to broken objects name mapping and updated ‘OrbitView’ and ‘GroundTrackPlot‘ projects and added the new field to the test.

            troyzman Tetyana Royzman made changes -
            Worklog Id 15667 [ 15667 ]
            Time Spent 1 day, 1 hour [ 32400 ] 1 day, 7 hours [ 54000 ]
            Remaining Estimate 1 day, 7 hours [ 54000 ] 1 day, 1 hour [ 32400 ]
            troyzman Tetyana Royzman logged work - 24/Aug/17 4:11 PM
            • Time Spent:
              6 hours
               

              updated name mapping, steps, and property checks for the system projects

            troyzman Tetyana Royzman made changes -
            Worklog Id 15668 [ 15668 ]
            Time Spent 1 day, 7 hours [ 54000 ] 2 days, 5 hours [ 75600 ]
            Remaining Estimate 1 day, 1 hour [ 32400 ] 3 hours [ 10800 ]
            troyzman Tetyana Royzman made changes -
            Worklog Id 15669 [ 15669 ]
            Time Spent 2 days, 5 hours [ 75600 ] 3 days, 3 hours [ 97200 ]
            Remaining Estimate 3 hours [ 10800 ] 0 minutes [ 0 ]
            troyzman Tetyana Royzman made changes -
            Worklog Id 15670 [ 15670 ]
            Time Spent 3 days, 3 hours [ 97200 ] 4 days, 1 hour [ 118800 ]
            shughes Steven Hughes made changes -
            Status Resolved [ 5 ] Closed [ 6 ]

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Time Tracking

                  Estimated:
                  Original Estimate - 3 days Original Estimate - 3 days
                  3d
                  Remaining:
                  Remaining Estimate - 0 minutes
                  0m
                  Logged:
                  Time Spent - 4 days, 1 hour
                  4d 1h