Uploaded image for project: 'GMAT'
  1. GMAT
  2. GMT-5654

OrbitView Doesn't Rename Spacecraft Properly and Moved to the Wrong Field

    Details

    • Type: Bug
    • Status: Closed (View Workflow)
    • Priority: P1
    • Resolution: Fixed
    • Affects Version/s: R2015a
    • Fix Version/s: R2016a
    • Component/s: Orbit View (FRR-28)
    • Labels:
    • Environment:

      Windows 7, Build 5/17/2016

      Description

      1. Open New Mission
      2. Rename DefaultSC to MySC
      3. Open OrbitView - there are two Spacecraft names there - the Old Spacecraft (DefaultSC) moved to Selected Celestial Object field and renamed Spacecraft (MySC) moved to Spacecraft field instead of staying in Selected Spacecraft field.

        Gliffy Diagrams

          Attachments

            Activity

            gmatloj Linda Jun added a comment -

            This issue was caused by ref. object not set for new default FiniteBurn Parameters that I added to Moderator.

            gmatloj Linda Jun added a comment -

            Fixed rename issue. The default ImpulsiveBurn object DefaultIB will be no longer shown in the GUI since this object is not used in the default mission. If this change causes too much problem in GUI testing, I'll convert it back. Fix is in 2016.05.20 build.

            troyzman Tetyana Royzman added a comment - - edited

            There DefaultOrbitView, DefaultGroundTrackPlotmissing, and Propagate are missing in the latest GMAT Build (5/23). When I try to open it, I get an error:
            Error occurred during default mission creation.
            The default mission will not run.
            Message: GmatBase Exception Thrown: Cannot get string parameter with ID 32:
            "OrbitErrorCovariance" on Spacecraft named "DefaultSC"

            gmatloj Linda Jun added a comment -

            Above issue is fixed in 2016-05-24 build.

            troyzman Tetyana Royzman added a comment -

            The issue fixed and closed.


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Time Tracking

                  Estimated:
                  Original Estimate - Not Specified
                  Not Specified
                  Remaining:
                  Remaining Estimate - 0 minutes
                  0m
                  Logged:
                  Time Spent - 7 hours
                  7h