Uploaded image for project: 'GMAT'
  1. GMAT
  2. GMT-2876

Infinite warning loop when running during animation

    Details

      Description

      1. Load infloop.script
      2. View the script
      3. Run the mission from the script editor
      4. Play the animation
      5. While the animation is running, run the mission again
      6. You'll get a warning: "The animation is running. Please stop the animation first."
      7. Try to dismiss the warning

      The warning keeps coming back, giving the user no chance to stop the animation.

        Gliffy Diagrams

          Attachments

            Activity

            rqureshi Rizwan Qureshi added a comment -

            hello Linda,

            Joel just reported in this bug. You are SDE for this feature so I am assigning this bug to u. Please let me know if this is an issue.

            shughes Steven Hughes added a comment -

            CCB: P1 2013a

            gmatloj Linda Jun added a comment -

            This is duplicate of GMT-2022.

            gmatloj Linda Jun added a comment -

            This is not the duplicate of GMT-2022 so reopened it.

            gmatloj Linda Jun added a comment -

            Fixed infinite warning loop.
            Actually I wanted to implement as YES/NO confirm message so that when user replies with Yes, it will stop the animation and rebuild and run the mission. But there was an issue I could not resolve was that the resource tree is always updated after mission run. So I implemented in the way user has to stop the animation first before reloading the GUI and run.

            jjkparker Joel Parker added a comment -

            Verified as fixed in 2012-08-02 build

            jjkparker Joel Parker added a comment -

            No additional work to be done


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Time Tracking

                  Estimated:
                  Original Estimate - Not Specified
                  Not Specified
                  Remaining:
                  Remaining Estimate - 0 minutes
                  0m
                  Logged:
                  Time Spent - 1 day, 4 hours
                  1d 4h