Uploaded image for project: 'GMAT'
  1. GMAT
  2. GMT-2011

Larger angular momentum errors in 09/15 build

    Details

      Description

      The 09/15 build contains numeric fixes to GMT-799. That build is showing reduced errors in a lot of cases, but increased errors in angular momentum for several interplanetary cases. I've attached a few test cases.

      In particular, Venus1_2Body_VenusFixed has an increase of 30cm in hX, and Venus1_2Body_VenusMJ2000Eq has an increase of 25cm in hY.

        Gliffy Diagrams

          Attachments

            Activity

            jjkparker Joel Parker created issue -
            jjkparker Joel Parker added a comment -

            Attachment CSParams_GMAT_Venus1_2Body_VenusFixed.m has been added with description: CSParams_GMAT_Venus1_2Body_VenusFixed.m

            jjkparker Joel Parker added a comment -

            Created an attachment (id=1135)
            CSParams_GMAT_Venus1_2Body_VenusFixed.m

            jjkparker Joel Parker added a comment -

            Attachment CSParams_GMAT_Venus1_2Body_VenusMJ2000Ec.m has been added with description: CSParams_GMAT_Venus1_2Body_VenusMJ2000Ec.m

            jjkparker Joel Parker added a comment -

            Created an attachment (id=1136)
            CSParams_GMAT_Venus1_2Body_VenusMJ2000Ec.m

            jjkparker Joel Parker added a comment -

            Attachment CSParams_GMAT_Venus1_2Body_VenusMJ2000Eq.m has been added with description: CSParams_GMAT_Venus1_2Body_VenusMJ2000Eq.m

            jjkparker Joel Parker added a comment -

            Created an attachment (id=1137)
            CSParams_GMAT_Venus1_2Body_VenusMJ2000Eq.m

            jjkparker Joel Parker added a comment -

            Attachment CSParams_GMAT_Moon_2Body_MoonFixed.m has been added with description: CSParams_GMAT_Moon_2Body_MoonFixed.m

            jjkparker Joel Parker added a comment -

            Created an attachment (id=1138)
            CSParams_GMAT_Moon_2Body_MoonFixed.m

            jjkparker Joel Parker added a comment -

            The numbers I quoted below aren't clear: the errors are 0.3 m^2/s and 0.25 m^2/s, which is 3000 cm^2/s and 2500 cm^2/s, respectively.

            jjkparker Joel Parker made changes -
            Field Original Value New Value
            Fix Version/s Sept 1 [ 10358 ]
            jjkparker Joel Parker made changes -
            Affects Version/s Development [ 10335 ]
            shughes Steven Hughes made changes -
            Component/s Dynamics Models (FRR-13) [ 10404 ]
            Component/s Calculation Parameters (FRR-38) [ 10515 ]
            gmat_wcs Wendy Shoan added a comment -

            CCB: P1

            gmat_wcs Wendy Shoan made changes -
            Priority P2 [ 3 ] P1 [ 1 ]
            Fix Version/s R2013a [ 10201 ]
            shughes Steven Hughes added a comment -

            assigning to myself for analysis

            shughes Steven Hughes made changes -
            Assignee Darrel Conway [ djcinsb ] Steven Hughes [ shughes ]
            jjkparker Joel Parker made changes -
            Assignee Steven Hughes [ shughes ] Joel Parker [ jjkparker ]
            jjkparker Joel Parker added a comment -

            These particular tests are very hard to diagnose, but I added new tests specifically for HX, HY, HZ for the CSParams_Moon case. I see no numeric issues.

            jjkparker Joel Parker made changes -
            Resolution Cannot Reproduce [ 5 ]
            Status Open [ 1 ] Resolved [ 5 ]
            jjkparker Joel Parker made changes -
            Status Resolved [ 5 ] Closed [ 6 ]

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: